Author Topic: v15.2 - Loss of MDG specific tags  (Read 2402 times)

Paolo F Cantoni

  • EA Guru
  • *****
  • Posts: 7947
  • Karma: +206/-127
  • Inconsistently correct systems DON'T EXIST!
    • View Profile
v15.2 - Loss of MDG specific tags
« on: July 19, 2021, 01:16:15 pm »
Normally, when I try to add a tag to an item (whether vertex or arc), using the Add Tag dialog, we get a list of tags some of which are prefixed by the MDG name and others not.  Those not are local to the repository, the others come from the enabled MDGs.

Recently, those tags from OUR MDG are missing from the list (they make a VERY long List since there are so many)  other MDG based Tags are visible in the list.  Does this mean there is some subtle problem with the tag definitions which s causing a silent fail or am I, again, the victim of a perspective?  My suspicion is the former.

Can anybody make any suggestions where to look?

TIA,
Paolo
Inconsistently correct systems DON'T EXIST!
... Therefore, aim for consistency; in the expectation of achieving correctness....
-Semantica-
Helsinki Principle Rules!

Paolo F Cantoni

  • EA Guru
  • *****
  • Posts: 7947
  • Karma: +206/-127
  • Inconsistently correct systems DON'T EXIST!
    • View Profile
Re: v15.2 - Loss of MDG specific tags
« Reply #1 on: July 20, 2021, 04:29:45 pm »
Sorted it... User error!  :(

The <DataSet line below
Code: [Select]
<TaggedValueTypes>
<RefData version="1.0" exporter="EA.25">
<DataSet name="Property Types" table="t_propertytypes" filter="Property='#Property#'">
had been changed to...
Code: [Select]
<TaggedValueTypes>
<RefData version="1.0" exporter="EA.25">
<DataSet name="Tagged Value Types" table="t_propertytypes" filter="Property='#Property#'">

So silent fail!  :o

("Not happy, Jan!" - about the silent fail...  Only took an hour to track it down.)

Paolo
Inconsistently correct systems DON'T EXIST!
... Therefore, aim for consistency; in the expectation of achieving correctness....
-Semantica-
Helsinki Principle Rules!