Author Topic: Configure WebEA models - via Web Browser  (Read 1956 times)

Modesto Vega

  • EA User
  • **
  • Posts: 635
  • Karma: +18/-8
    • View Profile
Configure WebEA models - via Web Browser
« on: November 06, 2021, 04:11:59 am »
When attempting to configure WebEA models via the browser as described in https://sparxsystems.com/enterprise_architect_user_guide/15.2/pro_cloud_server/configure_webea_via_web.html, we are getting the following error:
Quote
'includes/webea_config.ini' file is not writeable.
Please check that the 'includes/webea_config.ini' file permissions allow read/write access.

'includes' directory is not writeable
Please check that the 'includes' directory permissions allow read/write (create) access.
We are using IIS to host the WebEA  and WebConfig and the account running the application pool has Read & Write access to the includes folder.

Help is very welcomed.

Modesto Vega

  • EA User
  • **
  • Posts: 635
  • Karma: +18/-8
    • View Profile
Re: Configure WebEA models - via Web Browser
« Reply #1 on: November 10, 2021, 09:21:45 pm »
Any takers, I somehow cannot believe nobody has asked this before.

steen.jensen

  • EA User
  • **
  • Posts: 150
  • Karma: +6/-1
    • View Profile
Re: Configure WebEA models - via Web Browser
« Reply #2 on: November 11, 2021, 10:10:40 am »
Set read&Write to ALL, then you can check the file WHAT user did the write. Easy to misspel

Modesto Vega

  • EA User
  • **
  • Posts: 635
  • Karma: +18/-8
    • View Profile
Re: Configure WebEA models - via Web Browser
« Reply #3 on: November 13, 2021, 05:13:09 am »
This what we found so far. We want to use scenario 2.

Scenario 1
If we run the website using Anonymous Authentication, use the Application Pool Identity as the Anonymous Authentication Credentials, and give the Application Pool Identity Read & Write permissions to the includes folder, this page works. Therefore http://{yourwebserver}/login.php?config or http://{yourwebserver}/webea/login.php?config is using the Application Pool Identity to access the includes folder.

However, the login screen does not prompt the user to login (as expected) and always fails with an unspecified error irrespective of whether the model has security enabled or not.

Scenario 2
If we run the website using Windows Authentication and give an AD group Read & Write permissions to the includes folder, this page works, this page works for any user belonging to that group. Therefore http://{yourwebserver}/login.php?config or http://{yourwebserver}/webea/login.php?config is automatically using the windows login of the user accessing this page.

However, the login screen does not prompt the user to login and throws the following error, SSL certificate problem: unable to get local issuer certificate, irrespective of whether the model has security enabled or not. Adding sscs_use_ssl = "true" as suggested by https://sparxsystems.com/enterprise_architect_user_guide/15.2/model_repository/webea_troubleshoot.html, does not make a difference.

Any help is as usual very welcome. We have also submitted a support case.